Why is my Hisense TV Only play 1-minute episodes on Plex?

This is a very common issue for some Hisense models running on Vidaa OS.

Some possible causes and solutions are:

  • The Plex app on Vidaa OS may not be updated or supported anymore. You can try uninstalling and reinstalling the app, or checking for any software updates on your TV.
  • The Vidaa OS may not be compatible with Plex. You may want to consider using a different device to stream Plex, such as a Roku, Chromecast, or Firestick.
  • The Plex server may not be able to transcode the video files properly, or there may be some network issues. You can try adjusting the quality settings on the Plex app, or using a tool like Tautulli to monitor the server performance.

However, some folks on Reddit suggest changing the Plex settings on the TV to allow for insecure connections.

To do this,

  • Go to settings and find the “Advanced” section.
  • Now Set “Allow Insecure Connections” to “Always” as seen above.

The Plex server itself will need to have its “Secure connections” setting set to “Preferred”.

I hope this helps…

Can’t Find Your Answer?

Statement

Information you find here is completely accurate. Our writer carefully checks and verifies all the facts. We review the information every month and update it with the latest details.

Ethics

If you think the information written here is not entirely accurate, or if there is any misinformation, please feel free to let us know instantly. We are constantly striving to keep all articles updated.

Subscribe
Notify of
guest
0 Comments
Inline Feedbacks
View all comments